My Account  |  Cart  |  

Supported Combinations

This table identifies which design applications and operating system versions are supported for recent versions of Suitcase Fusion.

    Suitcase Fusion 7
(Current version)
Suitcase Fusion 6
(Support is available)
Suitcase Fusion 5
(No longer supported)
Creative Cloud 2017 macOS 10.10–10.12
  Windows 7 SP1, 8.1, 10
CC 2015 (Summer 2016) macOS 10.9–10.11
  Windows 7 SP1, 8.1, 10
CC 2015 macOS 10.9–10.11 10.9–10.11
  Windows 7 SP1, 8, 8.1, 10 7 SP1, 8, 8.1, 10
CC 2014 macOS 10.9–10.10 10.7–10.10
  Windows 7 SP1, 8, 8.1 7 SP1, 8, 8.1
Creative Cloud macOS 10.6–10.9 10.6–10.9
  Windows 7 SP1, 8, 8.1 7 SP1, 8, 8.1
Creative Suite 6 macOS 10.9–10.11 10.6–10.11 10.6–10.9
  Windows 7 SP1, 8.1, 10 7 SP1, 8.1, 10 7 SP1
CS 5.5 macOS 10.6 10.6
  Windows 7 SP1 7 SP1
CS 5 macOS 10.6 10.6
  Windows 7 SP1 7 SP1
QuarkXPress 2016 macOS 10.9–10.11
  Windows 7 SP1, 8.1, 10
QuarkXPress 2015 macOS 10.9–10.11 10.9–10.11
  Windows 7 SP1, 8, 8.1, 10 7 SP1, 8, 8.1, 10
QuarkXPress 10 macOS 10.9–10.10 10.8–10.10 10.8–10.9
  Windows 7 SP1, 8, 8.1 7 SP1, 8, 8.1 7 SP1, 8, 8.1
QuarkXPress 9 macOS 10.6–10.9 10.6–10.9
  Windows 7 SP1, 8 7 SP1, 8

Notes

  • Support for Creative Cloud 2017 was added in Suitcase Fusion 7 v18.2.
  • Support for macOS Sierra (v10.12) was added in Suitcase Fusion 7 v18.1.1.
  • Support for QuarkXPress 2016 and Adobe Creative Cloud 2015 (Summer 2016 Release) was added in Suitcase Fusion 7 v18.1.
  • Although Adobe does not officially support running Creative Suite 6 applications on Windows 10, Mac OS X 10.10, or Mac OS X 10.11, many people do so with little or no difficulty. We offer support for Suitcase Fusion’s auto-activation plug-ins for CS6 on these newer OSes. See this Knowledge Base article for more information.

System Requirements

System requirements for Suitcase Fusion and supported design applications are available here: