Portfolio 2016 Express System Requirements - Extensis.com

Portfolio 2016 Express
System Requirements

Final version: Windows - 2.5.0, Mac - 2.5.1

System Requirements

  • Windows 7 SP1, Windows 8, Windows 8.1, Windows 10

    —OR—

    macOS 10.9 to 10.12

  • 2 GB of RAM
  • 150MB disk space
  • 100 Mbit/s or faster network connection

NOTE: Portfolio Express 2.5.1 running on macOS Sierra has only been confirmed to work with Portfolio 2016 v2.5.3 running on Windows or Mac servers. If you are running an earlier version of Portfolio 2016 and need Sierra compatibility for Express clients, update your server to v2.5.3.