extensis-support-laptop-2000x425.jpg

What can we help you with?

ExpressView System Requirements

Release Notes are here.

Final version: 6.6.1

Note: ExpressView is not supported on Google Chrome or newer versions of FireFox due to lack of Netscape-style (NPAPI) plug-in support.

  • Windows XP, Windows Vista SP2, Windows 7, Windows 8, Windows Server 2003 SP2, or Server 2012
  • 1GHz Intel processor
  • 64MB RAM
  • Internet Explorer 10 or later
  • Firefox 25-51