My Account  |  Cart  |  

System Requirements

Suitcase TeamSync

  • An Extensis.com account for each team member
  • A copy of Suitcase Fusion 7 or later for each team member
  • For managing your team: Internet Explorer® 10 or later, Microsoft Edge, Safari® 7 or later, or the current release of Firefox® or Chrome™

See Full System Requirements

Suitcase Fusion for iOS

  • iPad®, iPhone®, or iPod touch® running iOS 9 or later
  • Suitcase Fusion® 7 or Suitcase TeamSync™ for macOS™ or Windows®

See Full System Requirements


Other Resources

Getting Started with Suitcase TeamSync